About the author

Related Articles


  1. 1


    I had the same problem as @mohitum007. In my case the developer of this App included an expiry date in it.

    As workaround I set the date backwards to a past date (e.g. last month). Then I could install it and use it.

    Also when I set the date back to normal, the already installed App didn’t start up anymore. I contacted the company of this App to send me an updated version.

    Sidenote: I found out that users from other Apps had the same problem but reversed: it won’t install or start before a certain date.

  2. 2


    As for Xcode 5.1, the problem was in arm64 architecture in VALID_ARCHS. Building the release configuration for 5.0 device locally gives the following error:

    Xcode cannot install or launch applications supporting the 64-bit architecture on devices running iOS versions prior to 6.0. This configuration is supported for distribution through the iOS App Store, but cannot be used during development with Xcode. To continue, edit the Run scheme action and select a build configuration that does not include the 64-bit architecture.

    Removing arm64 from VALID_ARCHS solves the issue. In my case I had to create a separate branch for testing on iOS 5 devices.

  3. 3

    David van Dugteren

    I ended up creating new Provisioning profiles, not sure if it was because of:

    “The ad hoc distribution provisioning profile is corrupted and the device is having an issue with it.”

  4. 4


    Here is what worked for me:

    1. Clear the Cache and Cookies (Settings > Safari).
    2. Remove existing profile (if any) linked to “Test Flight App” (Settings > General > Profiles).
    3. Open Safari and go to https://testflightapp.com/. Login and follow the steps to start over.

    P.S. I used to have a Test Flight App, but it looks like it crashed and the icon turned to be all white. Restarting my iPhone made it reappear correctly.

  5. 5


    Missing icon could be a problem. My manifest file points to a non-existing image and it fails the installation process. Placing an icon at the corresponding path solved the issue for me.

  6. 6


    I have had the same issue after fiddling around with certificates (argh).

    The problem became apparent as I followed the comment of @Duraiamuthan.H, I installed on a device. The device reported 0xe8008016 (Entitlements) see SO here

    The initial reason was, that the testflight target used the App store distribution certificate, not the Team certificate. I fixed that and the application was installing on the device over Xcode and then it also worked with testflight.

  7. 7


    Check if the deployment target in the General section of the project settings, is greater than that of your device’s iOS version.

    If yes then you need to update the version of your device to at least the deployment target version. in order for you to be able to install the application on your device.

  8. 8

    Evgeniy S

    in my case app want to use iCloud services, but in distr. provision profile wasn’t set iCloud enabled. turn it on and refresh profile.

  9. 9

    Confused Vorlon

    Watch the console through the Xcode Organiser for the device that is failing to install.

    You’ll get a helpful message from the system telling you what is wrong. There are lots of potential failure reasons, so unless you check the message, you’re just guessing…

  10. 10


    This can also happen if you disable cellular data for “App Store” (for example, while on vacation) and forget to turn it back on. The solution here is to simply re-enable it in Settings -> Cellular.

  11. 11

    Adetiloye Philip Kehinde

    I had this problem but I fixed this by making sure my Code Signing Identity is the SAME as the one I used in test flight.

    After that, everything works fine

  12. 12

    Steven Kramer

    I just saw this as a result of a network error / time-out on a flaky network. I could see the progress bar increasing after I got the bright idea of just retrying. Also saw HTTP Range requests on the download server with ever increasing offsets of a few megabytes (the entire app was about 44MB).

  13. 13


    For me Setting Build Active Architecture to NO… works and installed successfully

  14. 14

    Mike Gledhill

    I was also having this problem, with an Ad-Hoc iPad application, when trying
    to install it on a iOS 6 device.

    What fixed it for me was to click on the project in XCode, and change the
    iOS Deployment Target” setting from 5.1 to 6.0.

    And there was silly me thinking that iOS 5.1 apps would run on a iOS 6.0 device.

  15. 15


    Most common issues that cause this are (from testflight’s website):

    • Device storage is full
    • The provisioning profile is a developer provisioning profile
    • The ad hoc distribution provisioning profile is corrupted and the device is having an issue with it.
    • The device was restored from a backup and is causing a conflict for over-the-air distribution
    • There was a network timeout
    • Architecture settings of the build and the device are incompatible ( can sometimes happen -when “Build Active Architecture Only” is on when building).
    • Not Using Mobile Safari.

    for me it turned out that my client’s ipad was running iOS 4.2.2 and my project supports 5.0+.

  16. 16


    You can try to publish the application by changing the version of the build.
    I was also having the same problem and tried the same by just changing tIt may help you too.

  17. 17


    clear your cache and cookies in Safari, make sure your device is in provisioning profile and provisioning profile is installed on the device.

    If everything mentioned above didn’t help, try to create a new build with higher build number and try to distribute your app again

  18. 18


    I had similar issue. However, I was able to fix it when I updated my iPad timings to that of current. I just checked the device log and found that the time in the log was shown 2 years before.

    Hope updating the device timing to the current time will fix the issue.

  19. 19


    Recently default Xcode project settings set ONLY_ACTIVE_ARCH (Build Active Architecture Only) to yes for Debug configuration.
    So your build can not be installed on different hardware than the one you use for development.
    Change this setting and installation should go fine.
    enter image description here


Leave a Reply to xardas Cancel Reply

Your email address will not be published. Required fields are marked *

Copyright © 2017 SolutionMmyself.com