About the author

Related Articles

20 Comments

  1. 1
    Nadzeya@email.null'

    Nadzeya

    It seems that if you only have developer’s certificate in your Keychain, you can’t export Ad Hoc builds. You must have a distribution certificate as well as a distribution provision profile

    Reply
  2. 2
    Stackhelper@email.null'

    Stackhelper

    Problem at my end was, in itunesconnect my account was certified as “iOS developer” but not as “iOS app distributor”. Had to recreate certificate, download it, open with keychain , and then revalidate the archive. It finally worked. Thanks all

    Reply
  3. 3
    Linda@email.null'

    Linda

    Only this way solved the issue for me:
    Open the “Keychain Access” app and select “View” -> “Show Expired Certificates”. Remove ALL expired Apple certificates!
    Restart Xcode.

    See: Xcode unable to create distribution builds for App Store submissions or Enterprise apps -> https://developer.apple.com/support/certificates/expiration/

    Reply
  4. 4
    genaks@email.null'

    genaks

    Not sure why ‘Use local signing assets’ worked for me

    Reply
  5. 5
    XIII@email.null'

    XIII

    In my case “Xcode 7.3” all i needed was to clean the project, restart Xcode, re-archive and it’s all fine.

    Reply
  6. 6
    Vijay

    Vijay Parchani

    This must be an issue with the team you have selected. If you have created a new bundle id from some other apple account which is not added in your xcode preferences follow the below steps to add new team.

    Step 1: Go to xcode preference.
    Step 2: Click on Accounts tab.
    Step 3: Click on (+) icon to add new account.
    Step 4: Login with developer account credential
    Step 5: Click on 'Done'
    
    Reply
  7. 7
    Anibal

    Anibal Rodriguez

    In keychain access, -> Show Expired Certificates, then in your login keychain click on expired certificate and delete it. I also had the same expired certificate in my System keychain, so I deleted it from there too.

    -> After deleting the expired cert from the login and System keychains,download certificate from below link and open with keychain.

    Download https://developer.apple.com/certificationauthority/AppleWWDRCA.cer and add it to Keychain access > certificates (which expires on 2023)

    this solved my problem

    Reply
  8. 8
    james_t@email.null'

    james_t

    I could see my Distribution certificate in the keychain, but it was unsigned. I solved this by going to the Dev site, clearing out all certificates and provisioning profiles (yes, deleting all), and re-gen the certificates (dev and dist) and download and clearing old certs and importing new into keychain. Also if you have more than one app ID, generate the distribution profile and download in import else Xcode mgmgt may choose the wrong app to create the profile (happened to me). Restarting XCode, I made sure that the iOS Distribution was chosen in my apps Target signing section (it was not). XCode remade the prov-profiles for me. It passed signing validation (ugh now on to 64-bit support!)

    Reply
  9. 9
    Kendall

    Kendall Helmstetter Gelner

    I got this error when having multiple development accounts/teams I was on. The solution for me was to make sure that all of the following were properly set up:

    1. I had a distribution certificate with private key for the account
      the app belonged to (if someone else has made the certificate you have to key the private key from them and install it).
    2. I had a specific (not wildcard) application ID
      (as in com.mycompany.myapp).
    3. I had a provisioning profile that was
      created using the distribution certificate mentioned above along
      with the AppID mentioned above.

    When all of that is in place, you can refresh your account in Xcode and you should not get that message anymore…

    Reply
  10. 10
    zeeawan@email.null'

    zeeawan

    I got same issue. I was pretty sure about my provisioning and certificate etc are properly set. I created all these at apple dev portal while my Xcode 6.2 was opened. After downloading certificate and provisioning, I double clicked both and then was able to choose for signing from Xcode. That is NO Xcode restart needed up-to this point as new provisioning file is available to be chosen from Xcode. Then I archived the binary and it opened in Organizer for submission.

    But here comes the actual issue that Organiser is not aware about my true assets. So, here we need to restart the Organiser (Xcode). I must say a bug at Apple’s end to not make Organiser aware about the updated assets. As after restarting the Organiser, I submitted the app and it prompted to allow to sign certificate from Keychain.

    Reply
  11. 11
    Alix@email.null'

    Alix

    I have been searching answer for this problem past 6 hours. Nothing is satisfactory. As no one knows why this is happening.
    Following is way to generate .ipa via command line. If that works I will update here tomorrow.

    xcodebuild -exportArchive -archivePath $projectname.xcarchive -exportPath $projectname -exportFormat ipa -exportProvisioningProfile “Provisioning Profile Name”

    Note : The “Provisioning Profile Name” is the name specified in the name field of the certificate (viewable from developer.apple.com).

    This will create .ipa.

    credit goes to Orginal author here

    This trick worked for me.

    Reply
  12. 12
    Imeksbank@email.null'

    Imeksbank

    Had same problem and now i can EXPORT my App again.
    1) this reply was very funny but good NOT TO HEAR ANYONE combining with
    2) answered Sep 19 ’14 at 23:21
    hepled me to get work on my iPhone.

    Go to development.apple.com -> Certificates -> All / Production and just delete you iOS Distribution thing. It could be so that you deleted all certificates local and it does not match the original anymore thats why you have this message with this image =) As i said i had the same problem. After deleting just Archive and Export new and it will do this for you automaticly.

    Version 6.1.1 (6A2008a)

    Reply
  13. 13
    Nisari

    Nisari Balakrishnan

    In XCODE 6 when we create a provisioning profile it should be of type ADHOC.Set the profile in build settings and then archive.Everything will work fine I guess

    Reply
  14. 14
    user3545727@email.null'

    user3545727

    Don’t listen to anyone.

    DO NEXT:

    1. Open XCODE
    2. Go to Xcode > Preferences > View Details
    3. You will see Signing Identifies at the top of new opened window. There will be “iOS Development” or “iOS Distribution”. (in my case there was only 1 – iOS Development)
    4. Revoke all Signing Identifies you have there
    5. Click “+” button and click “iOS Development” then “iOS Distribution”. Now you are requesting new identifies!

    FINISH! ONLY 5 STEPS

    Reply
  15. 15
    user2527666@email.null'

    user2527666

    For me, all I had to do was restart XCode and it worked.

    Reply
  16. 16
    kraftydevil@email.null'

    kraftydevil

    This can happen when attempting the first release with a new Xcode version on the same Mac.

    In my case I had both Xcode 6 and Xcode 5 installed.

    I solved the issue by exporting my .developerprofile in Xcode 5 and then importing it in Xcode 6 as follows:

    In old Xcode (mine was 5.1.1)

    1. Go to Xcode > Preferences > Accounts
    2. Select Gear icon in bottom left
    3. Select Export Accounts
    4. Set the file to save in a place you’ll find easily
    5. Enter password that you’ll use when importing
    6. Select Save

    In new Xcode (mine was 6.0.1)

    1. Go to Xcode > Preferences > Accounts
    2. Select Gear icon in bottom left
    3. Select Import Accounts
    4. Select the .developerprofile file
    5. Enter the password and you will now be able to continue.

    This works from old Mac to new Mac as well.

    Reply
  17. 17
    Hari

    Hari Raja

    I was able to resolve this issue by renaming the provisioning profile name in member center and refreshing in XCode 6.

    Reply
  18. 18
    nyekimov@email.null'

    nyekimov

    I edited distribution profile and downloaded it again, restarted xcode and it worked.

    Reply
  19. 19
    TooManyEduardos@email.null'

    TooManyEduardos

    I got the same thing the first time, and then I realized that in the dev site there was a new provisioning profile that started with XC:
    I restarted xcode and xcode automatically found the XC: profile it created earlier and allowed me to sign the app.
    It looked as if the restart of xcode and refresh of signatures (after signing in while uploading/verifying the app on xcode) did the trick

    Reply
  20. 20
    Upendar

    Upendar Gareri

    I was also facing the same issue when using Xcode 6 GM and so I used Xcode 5.1 to create the ipa file.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Copyright © 2017 SolutionMmyself.com